Junos/IOS RSVP tunnel configuration

root@Juniper> show configuration interfaces

em0 {

unit 0 {

family inet {

address 10.1.2.2/24;

}

family mpls; ## configure family mpls to process mpls packets

}

}

em1 {

unit 0 {

family inet {

address 10.2.2.2/24;

}

family mpls;

}

}

lo0 {

unit 0 {

family inet {

address 2.2.2.2/32;

}

}

}

root@Juniper> show configuration protocols ospf

traffic-engineering; ## To enable OSPF TE

area 0.0.0.0 {

interface em0.0;

interface em1.0;

interface lo0.0;

}

root@Juniper> show configuration protocols rsvp

interface all;

interface em2.0 {

link-protection; ## to enable link protections for this interface

}

root@Juniper> show configuration protocols mpls

traffic-engineering mpls-forwarding; ## To copy inet.3 routes to inet.0 and use for forwarding

admin-groups { ## to create admin-group

gold 1;

silver 5;

bronze 10;

}

no-propagate-ttl; ## Altering TTL behaviour

explicit-null; ## sends label 1 instead of 3 to PHP

label-switched-path to-R1 {

to 1.1.1.1; ## egress router ID

adaptive; ## to use shared explict (SE)

fast-reroute { ## enable fast reroute for this LSP

hop-limit 10;

bandwidth 100m;

}

primary via-R0; ## Primary path via R0

secondary direct-to-R1 { ## standby secondary path

standby;

}

}

label-switched-path to-R3 {

to 3.3.3.3;

bandwidth 50m; ## BW request for this LSP

no-decrement-ttl;

priority 5 5; ## Setup and hold priority

admin-group include-any [ gold silver ]; ## Include either admin group

link-protection;

}

path via-R0 { ## strict ERO

10.1.2.1 strict;

}

path direct-to-R1 {

10.2.2.1;

}

interface all;

interface em0.0 {

admin-group [ gold bronze ];

}

root@Juniper> show mpls lsp ingress detail

Ingress LSP: 2 sessions

1.1.1.1

From: 2.2.2.2, State: Up, ActiveRoute: 0, LSPname: to-R1

ActivePath: via-R0 (primary)

FastReroute desired

LoadBalance: Random

Encoding type: Packet, Switching type: Packet, GPID: IPv4

*Primary via-R0 State: Up

SmartOptimizeTimer: 180

Computed ERO (S [L] denotes strict [loose] hops): (CSPF metric: 2)

10.1.2.1 S 10.1.1.2 S

Received RRO (ProtectionFlag 1=Available 2=InUse 4=B/W 8=Node 10=SoftPreempt):

10.1.2.1 10.1.1.2

Standby direct-to-R1 State: Up

SmartOptimizeTimer: 180

Computed ERO (S [L] denotes strict [loose] hops): (CSPF metric: 1)

10.2.2.1 S

Received RRO (ProtectionFlag 1=Available 2=InUse 4=B/W 8=Node 10=SoftPreempt):

10.2.2.1

3.3.3.3

From: 0.0.0.0, State: Dn, ActiveRoute: 0, LSPname: to-R3

ActivePath: (none)

Link protection desired

LoadBalance: Random

Encoding type: Packet, Switching type: Packet, GPID: IPv4

Primary State: Dn, No-decrement-ttl

Priorities: 5 5

Bandwidth: 50Mbps

SmartOptimizeTimer: 180

Include Any: silver gold

Will be enqueued for recomputation in 24 second(s).

1 Nov 21 12:05:57.169 CSPF failed: no route toward 3.3.3.3[81 times]

Total 2 displayed, Up 1, Down 1

root@Juniper> show route table inet.3

inet.3: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

+ = Active Route, – = Last Active, * = Both

1.1.1.1/32 *[RSVP/7] 00:39:59, metric 2

> to 10.1.2.1 via em0.0, label-switched-path to-R1

to 10.2.2.1 via em1.0, label-switched-path to-R1

root@Juniper> show route table inet.3 detail

inet.3: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

1.1.1.1/32 (1 entry, 1 announced)

State: <FlashAll CalcForwarding>

*RSVP Preference: 7

Next hop type: Router

Next-hop reference count: 4

Next hop: 10.1.2.1 via em0.0 weight 0x1, selected

Label-switched-path to-R1

Label operation: Push 18

Next hop: 10.2.2.1 via em1.0 weight 0x2001

Label-switched-path to-R1 ## For standby which is via direct link

Label operation: Push 0

State: <Active ForwardingOnly Int>

Local AS: 65010

Age: 40:02 Metric: 2

Task: RSVP

Announcement bits (1): 1-Resolve tree 1

AS path: I

root@Juniper> show route 1.1.1.1/32

inet.0: 9 destinations, 10 routes (9 active, 0 holddown, 0 hidden)

@ = Routing Use Only, # = Forwarding Use Only

+ = Active Route, – = Last Active, * = Both

1.1.1.1/32   @[OSPF/10] 00:40:18, metric 2

> to 10.2.2.1 via em1.0

#[RSVP/7] 00:40:18, metric 2

> to 10.1.2.1 via em0.0, label-switched-path to-R1

to 10.2.2.1 via em1.0, label-switched-path to-R1

inet.3: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

+ = Active Route, – = Last Active, * = Both

1.1.1.1/32     *[RSVP/7] 00:40:18, metric 2

> to 10.1.2.1 via em0.0, label-switched-path to-R1

to 10.2.2.1 via em1.0, label-switched-path to-R1

root@Juniper>

@–JUNOS1 (RID:2.2.2.2) — R0(RID:100.100.100.100) — R1(RID:1.1.1.1)—@

<Cisco Configuration>

!

mpls traffic-eng tunnels

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Tunnel10

ip unnumbered Loopback0

mpls traffic-eng tunnels

tunnel destination 2.2.2.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 dynamic

!

interface FastEthernet0/0

ip address 10.1.1.2 255.255.255.0

duplex auto

speed auto

mpls traffic-eng tunnels

ip rsvp bandwidth

ip rsvp resource-provider none

!

interface FastEthernet0/1

ip address 10.2.2.1 255.255.255.0

duplex auto

speed auto

mpls traffic-eng tunnels

ip rsvp bandwidth

ip rsvp resource-provider none

!

router ospf 1

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

mpls traffic-eng interface FastEthernet0/1 area 0

mpls traffic-eng interface FastEthernet0/0 area 0

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0

network 10.1.1.0 0.0.0.255 area 0

network 10.2.2.0 0.0.0.255 area 0

!

R1#show mpls traffic-eng tunnels brief

Signalling Summary:

LSP Tunnels Process: running

RSVP Process: running

Forwarding: enabled

Periodic reoptimization: every 3600 seconds, next in 331 seconds

Periodic auto-bw collection: disabled

TUNNEL NAME                      DESTINATION               UP IF             DOWN IF          STATE/PROT

R1_t                                             10 2.2.2.2                             –                     Fa0/0                up/up

to-R                                              1 1.1.1.1                             Fa0/0                    –                     up/up

to-R                                              1 1.1.1.1                             Fa0/1                     –                     up/up

Displayed 1 (of 1) heads, 0 (of 0) midpoints, 2 (of 2) tails

Topology:


Advertisements
This entry was posted in IOS, jncis, Junos, mpls, rsvp and tagged , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s