Junos sample ISIS Configuration

root@Juniper> show configuration protocols isis

traceoptions { ## to store debug information to file “isis-test”

file isis-test;

flag all receive detail; ## debug on all isis received packets

}

export [ route-leak-L2-L1 summary-L1-L2 ]; ## export map for route leak and summarization

reference-bandwidth 2g; # # global reference BW command

overload timeout 100; ## ISIS neighbors will not use LSP generated by this router for 100 sec

level 2 { ## MD5 authentication for level-2 neighbors

authentication-key “$9$xno-YoDjqQF/ZUjq.Pn6”; ## SECRET-DATA

authentication-type md5;

wide-metrics-only; ## use wide-metric for level-2

}

level 1 { ## simple text password for level-1 neighbors

authentication-key “$9$CgOTpIcKvLVwgrevLX7Y2”; ## SECRET-DATA

authentication-type simple;

}

interface em0.0 {

mesh-group 1000; ## interface is assigned with mesh value of 1000

level 1 {

metric 50; ## Level-1 interface metric is set to 50. Default 10.

priority 127; ## Priority changed for 127 for DIS election. default 64

}

level 2 disable; ## level-2 disabled on this interface

}

interface em1.0 {

point-to-point; ## network type is set to p2p. NO DIS.

level 1 disable; ## Level-1 disabled on this interface.

}

interface em2.0 {

hello-padding adaptive; ##configure padding until state of neighbor adjacency is up

passive; ## adjacency will not be formed. only route advertisement.

checksum; ## to enable checksum on interface. Not necessary for passive interface.

}

interface lo0.0; ## Loopback interface added for adjacency to form.

root@Juniper> show configuration interfaces em0

unit 0 {

family inet {

address 10.1.2.2/24;

}

family iso; ## Family iso command enabled to accept isis packets

}

root@Juniper> show configuration interfaces em1

unit 0 {

family inet {

address 10.2.2.2/24;

}

family iso;

}

root@Juniper> show configuration interfaces lo0

unit 0 {

family iso {

address 49.0001.2222.2222.2222.00; ## Net ID configured on loopback interface

}

}

root@Juniper> show configuration policy-options

policy-statement route-leak-L2-L1 {

term L2-L1 {

from {

protocol isis;

level 2;

}

to level 1;

then accept;

}

}

policy-statement summary-L1-L2 {

term reject-summarized {

from {

route-filter 170.1.1.0/21 orlonger;

}

to level 2;

then reject;

}

term advertise-summary {

from protocol aggregate;

to level 2;

then accept;

}

}

root@Juniper> show isis adjacency

Interface             System         L State        Hold (secs) SNPA

em0.0                 R0             1  Up                   21  cc:0:c:80:0:1

em1.0                 R1             2  Up                   26

root@Juniper> show isis database level 2 R0.00-00 extensive | find TLV

TLVs:

Area address: 49.0001 (3)

Speaks: IP

Hostname: R0

IP address: 10.1.2.1

IP extended prefix: 10.1.2.0/24 metric 10 up

IS extended neighbor: Juniper.02, Metric: default 10

IP extended prefix: 170.1.1.0/24 metric 10 up

IP extended prefix: 170.1.2.0/24 metric 10 up

IP extended prefix: 170.1.3.0/24 metric 10 up

IP extended prefix: 170.1.4.0/24 metric 10 up

No queued transmissions

root@Juniper>

Advertisements
This entry was posted in is-is, jncis, Junos and tagged , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s